Back to overview
Downtime

Connect Platform is down

Feb 27, 2024 at 6:07pm UTC
Affected services
Connect Platform

Resolved
Feb 27, 2024 at 6:12pm UTC

Connect Platform recovered

Created
Feb 27, 2024 at 6:07pm UTC

Connect Platform is under maintenance